Jetzt neu: PHP 8.3 verfügbar – Abschaltung von PHP 5.6

Neue Umgebung für alle Webseiten rein, Altlasten raus!

Ab sofort steht für alle webmaster bei bplaced PHP 8.3 zur Verfügung – die neue Veröffentlichung kann unter https://my.bplaced.net/php ausgewählt werden. Vorgenommene Änderungen werden nach etwa einer halben Stunde aktiv.

Alle Neuerungen sind unter https://www.php.net/releases/8.3/de.php zusammengefasst und beinhalten unter anderem (für alle, die es genauer wissen möchten) typisierte Klassenkonstanten, die Prüfung auf Korrektheit von JSON via json_validate() und sogar negativen Indizes für arrays, was mal eine unerwartete Neuerung ist.

print_r(
    json_validate('{"katze": { "mag": "hunde" } }')
);

# Ergebnis
bool(true)


$array = [];

$array[]   = 'c';
$array[1]  = 'a';
$array[-1] = 't';

print_r($array, true);

# Ergebnis:
Array
(
    [0] => c
    [1] => a
    [-1] => t
)

Dabei ist für PHP 8.2 auch der ionCube-Loader hinzugekommen – zur neuen Veröffentlichung von 8.3 hat es dieser seitens des Herstellers noch nicht geschafft, wird jedoch bei Erscheinen nachgereicht.

Die Infoseite zur aktuellen Version kann unter https://phpinfo.bplaced.net/ eingesehen werden.

PHP 5.6 adé!

Nun, nicht so schnell! Wir haben tatsächlich noch so einige Spätsünder, welche noch nicht auf eine neuere PHP-Version umgestellt haben.

Da wir allerdings demnächst auch wieder unsere Serversysteme runderneuern möchten, wird die Verwendung von 5.6 nicht mehr so einfach möglich sein. Denn die noch bis 2018 unterstützte Umgebung, wird heute nicht mehr weiterentwickelt und steht bei bplaced allen voran noch aus Kompatibilitätsgründen zur Verfügung.

Hierzu haben wir zur Abschaltung bzw. automatischen Umstellung auf zumindest PHP 7.4 noch ein Zeitfenster bis Mitte des Jahres angesetzt, wobei davon später ebenso PHP 7.0 bis 7.3 betroffen wären.

Dennoch werden alle Betroffenen hierzu noch rechtzeitig informiert.

Fragen? Gerne steht unser Support zu allen Anliegen rundum PHP und sowieso zu allen anderen Themen gerne zur Verfügung!

Abonnieren
E-Mail senden für
guest
3 Comments
Älteste Kommentare
Neuste Kommentare
Inline Feedbacks
View all comments
X Æ A-12
X Æ A-12
14 days ago

php 5.6 ist doch uralt wieso wird das noch unterstützt?

miro
bplaced
13 days ago
Reply to  X Æ A-12

Ja, das ist tatsächlich mehr als betucht. Wir haben damals 2007 mit PHP 5 angefangen (siehe https://inside.bplaced.net/bplaced-feiert-geburtstag/) und es einfach nicht radikal abgestellt,da viele die Version schlichtweg nicht ändern.

Sei es aus Unwissenheit oder einfach weil PHP nicht verwendet wird, sondern nur statische Seiten. Prinzipiell spricht nicht unbedingt was dagegen, da wir z.B. Rechtetrennung implementieren und sich so Sicherheitsprobleme nur sehr beschränkt ergeben können.

Die Umstellung wird jedoch kommen müssen, da derart angestaubte Software nicht mit modernen Umgebungen kompatibel ist, sodass schon viel getrickst und modifiziert werden musste, um diese überhaupt noch im Portfolio der PHP-Versionen halten zu können.

Ela
Ela
4 days ago

Aber viele Foren und Homepage laufen noch auf PHP5.6

Heißt das,das diese bald nicht mehr laufen ?

3
0
Would love your thoughts, please comment.x